post

WordPress released its 4.5 version called Coleman on April 12.

Along with the interesting features like the responsive view toggle in the customizer, came a few problems that effected some of our themes.

Indie Pro, and Eryn Pro were reported to have issues since the upgrade to 4.5

Indie Pro was the worse effected by the upgrade with a complete failure of the customizer options. After a bit of investigation it turned out to be a naming conflict. Any customizer option that had a “widget_” prefix for a name broke the customizer. We swapped these out for a different name and everything started working again.

A second issue was relating to jQuery. WordPress core updated the version of jQuery it uses. As a result a snippet of code broke the javascript and the smooth scrolling effect.

The code below is incorrect. The link location (hash marks, #, in this case) should be quoted:

$('a[href*=#]:not([href=#])').click(function() {
...
});

to this

$('a[href*="#"]:not([href="#"])').click(function() {
...
});

We’ve rolled out updates to both Indie Pro and Eryn Pro that will fix these issues. Our free versions listed on WordPress.org have also had updates submitted.

We will go through the rest of our themes checking for this issues over the next couple of days.

Thanks